Probleme mit der Monitorkalibrierung unter Windows Vista

Die Freude an dem mit der Spyder 2 Suite kalibrierten und damit entblaustichten Bild meines Lenovo Notebooks währte leider nur kurz. Genau gesagt bis zum nächsten Reboot, bei dem das Display nur kurz das Colorvision-Logo samt kalibriertem Monitorbild zeigte und gleich darauf in den alten Blaustich zurückfiel.

Erste Recherchen im Internet ergaben, dass es sich hierbei wohl um eine Unverträglichkeit des Vista-Grafiktreibers der Intel-Onboard-Grafik mit Monitorprofilen im Allgemeinen handelt.

Da ich wohl nicht der einzige mit diesem Problem bin, möchte ich hier auf einige Lösungsmöglichkeiten, die ich zwischenzeitlich recherchiert und selbst herausgefunden habe.

Grafikkarte vergisst das Profil kurz nach dem Anmelden

Man deaktiviert alle per Autostart ausgeführten Teile des Grafiktreibers (die für den normalen Betrieb ohnehin gar nicht nötig sind) per msconfig. Man kann dazu auch ein anderes Programm, z.B. Autoruns aus den SysInternals, verwenden. Die Namen der betroffenen Programme beginnen alle mit igfx*.

(Alternativ kann man auch das Progrämmchen, das das Profil in die Grafikkarte lädt („Colorvision Startup“) manuell nach dem Reboot starten und somit sicherstellen, dass die Grafiktreiber-Zusatzprogramme schon laufen und das Profil nicht versaubeuteln.)

Nach dieser Aktion überstand das kalibrierte Profil bei mir schadlos Reboots und Neuanmeldungen und der olle Blaustich schien für immer der Vergangenheit anzugehören.

Bis, ja bis ich zum ersten mal eine administrative Tätigkeit auf dem Notebook machte, vor der mich Vista per User Account Control fragte, ob ich das denn wirklich wolle (ich finde diese Funktion übrigens ganz gut).

Nach der Bestätigung der Dialogbox auf dem Secure Desktop erstrahlte mein normaler Vista Desktop wieder BLÄULICH, uuuuaaaahhhhhhhh!!!!

Grafikkarte vergisst das Profil nach Rückfragen der UAC

Nach zwei Mailwechseln mit dem Colorvision-Support (der übrigens blitzschnell mit von Menschen verfassten, zielgerichteten Antworten reagiert hat – ist man heutzutage gar nicht mehr gewohnt…) ergab sich folgender Workaround:

Man muss das Display zweimal hintereinander Kalibrieren und die Ergebnisse unter zwei verschiedenen Profilnamen speichern. Dann kann man, wenn die Grafikkarte wieder mal das Profil vergessen hat, mit dem „ProfileChooser“ (Programmteil der Spyder Suite) kurz zwischen den beiden Profilen wechseln und so wieder ein kalibriertes Profil in die Grafikkarte laden (ziemlich umständlich…).

Laut Colorvision-Support ist die ganze Misere wahrscheinlich auf einen Fehler in den Intel-Grafiktreibern zurückzuführen, die beim Umschalten zwischen den Desktops das Monitorprofil zurücksetzen, aber dem Betriebssystem vorgaukeln, dass das ursprünglich geladene Profil immer noch geladen ist.

Beim weiteren Herumprobieren fand ich eine weitere, einfachere Lösung heraus:

Sobald das Display unkalibriert erscheint, sperrt man kurz den Desktop mittels [WIN]+L und entsperrt ihn dann durch Eingabe des Passworts gleich wieder. Danach wird – zumindest bei meinem Notebook – wieder das kalibrierte Profil geladen und das Display zeigt ein neutrales Bild.

3 Antworten zu “Probleme mit der Monitorkalibrierung unter Windows Vista”

  1. Thorsten sagt:

    Hallo Unbekannter, hatte das gleiche Problem mit Vista/Intel/ColorVision und fand nun endlich einen einfachen Weg, aus dieser Misere heraus zu kommen. Vielen Dank für die Anleitung (Ausführung), mit freundlichen Grüßen aus Tauberbischofsheim (Deutschland :-)), Thorsten.

  2. Ich möchte mich dem Dank meines Vorschreibers anschließen. Nach mehrtägiger Suche und und dem Test verschiedenster Szenarien ist dies der erste Workaround, der auch bei mir funktionierte.

    Ich habe Windows 7, es funktioniert also auch da.

    Vielen Dank!

  3. Noch ein Nachtrag. Entscheidend ist wohl folgendes:

    Man deaktiviert alle per Autostart ausgeführten Teile des Grafiktreibers (die für den normalen Betrieb ohnehin gar nicht nötig sind) per msconfig. Man kann dazu auch ein anderes Programm, z.B. Autoruns aus den SysInternals, verwenden. Die Namen der betroffenen Programme beginnen alle mit igfx*.

    Ich habe weder eine Spyder-Suite, noch verwende ich bei meinem Laptop (Toshiba) den eingebauten Bildschirm, sondern einen externen Monitor von Samsung.

    Ich habe mir bis hierher „’nen Wolf gesucht“…

    Danke nochmals.

Hinterlasse eine Antwort